$re = '/\bB\w{4}r\b/';
$str = '"Butter is good Buffer"
"I love Butter"
"Where my Butter is?"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);