re = /\bB\w{4}r\b/
str = '"Butter is good Buffer"
"I love Butter"
"Where my Butter is?"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end