re = /\b[(]?(?P<areaCode>\d{3})[)]?[ .-](?P<phone>\d{3}[ .-]\d{4})\b/
str = 'YES
(800)-555-1234
212 777.6789
Phone: 800 555-6879.
NO
1234567891011
abc def-ghij
800 def.ghij
Phone: 1234567891011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end