const regex = /62[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('62[0-9]+$', 'gm')
const str = `6281999200
62819992s00
6281999200a
081999200
a81999200
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}