#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?,,+.*$"
Local $sString = "hello,,457" & @CRLF & _
",,,,," & @CRLF & _
"dog,,,elephant,,,,,"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)