use strict;
my $str = 'hello,,457
,,,,,
dog,,,elephant,,,,,';
my $regex = qr/^.*?,,+.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";