$re = '/^.*?,,+.*$/m';
$str = 'hello,,457
,,,,,
dog,,,elephant,,,,,';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;