package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\s)([A-Z]+)(?:\s|$)`)
var str = `HELLO (this is good)
HeLL0 (not good)
H$L&0 (not good)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}