$re = '/(?:^|\s)([A-Z]+)(?:\s|$)/m';
$str = 'HELLO (this is good)
HeLL0 (not good)
H$L&0 (not good)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);