re = /(?:^|\s)([A-Z]+)(?:\s|$)/m
str = 'HELLO (this is good)
HeLL0 (not good)
H$L&0 (not good)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end