import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{.*\\})";
final String string = "some random text fjijd {\"Type\":\"NewTunnel\",\"Payload\":{\"ReqId\":\"e425ebb50d220816\",\"Url\":\"asaa\",\"Protocol\":\"http\",\"Error\":\"\"}} some other text bla bla\n\n"
+ "some random text fjijd {\"Type\":\"N{ewTunnel\",\"Payload\":{\"ReqId\":\"e425ebb50d220816\",\"Url\":\"asaa\",\"Protocol\":}\"http\",}\"Error\":\"\"}} some other text bla bla";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}