const regex = /({.*})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({.*})', 'g')
const str = `some random text fjijd {"Type":"NewTunnel","Payload":{"ReqId":"e425ebb50d220816","Url":"asaa","Protocol":"http","Error":""}} some other text bla bla
some random text fjijd {"Type":"N{ewTunnel","Payload":{"ReqId":"e425ebb50d220816","Url":"asaa","Protocol":}"http",}"Error":""}} some other text bla bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}