re = /({.*})/
str = 'some random text fjijd {"Type":"NewTunnel","Payload":{"ReqId":"e425ebb50d220816","Url":"asaa","Protocol":"http","Error":""}} some other text bla bla
some random text fjijd {"Type":"N{ewTunnel","Payload":{"ReqId":"e425ebb50d220816","Url":"asaa","Protocol":}"http",}"Error":""}} some other text bla bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end