using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:{).*(?:}))";
string input = @"some random text fjijd {""Type"":""NewTunnel"",""Payload"":{""ReqId"":""e425ebb50d220816"",""Url"":""asaa"",""Protocol"":""http"",""Error"":""}} some other text bla bla
some random text fjijd {""Type"":""N{ewTunnel"",""Payload"":{""ReqId"":""e425ebb50d220816"",""Url"":""asaa"",""Protocol"":}""http"",}""Error"":""}} some other text bla bla";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}