$re = '/((?:{).*(?:}))/';
$str = 'some random text fjijd {"Type":"NewTunnel","Payload":{"ReqId":"e425ebb50d220816","Url":"asaa","Protocol":"http","Error":""}} some other text bla bla
some random text fjijd {"Type":"N{ewTunnel","Payload":{"ReqId":"e425ebb50d220816","Url":"asaa","Protocol":}"http",}"Error":""}} some other text bla bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);