// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:{).*(?:}))").unwrap();
let string = "some random text fjijd {\"Type\":\"NewTunnel\",\"Payload\":{\"ReqId\":\"e425ebb50d220816\",\"Url\":\"asaa\",\"Protocol\":\"http\",\"Error\":\"\"}} some other text bla bla
some random text fjijd {\"Type\":\"N{ewTunnel\",\"Payload\":{\"ReqId\":\"e425ebb50d220816\",\"Url\":\"asaa\",\"Protocol\":}\"http\",}\"Error\":\"\"}} some other text bla bla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}