import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Produktabmessungen\\K(.+)";
final String string = "Artikelgewicht3,7 Kg\n"
+ "Produktabmessungen60,4 x 46,5 x 42 cm\n\n"
+ "or\n\n"
+ "Artikelgewicht3,7 Kg\n"
+ "Produktabmessungen60 x 46 x 42\n\n"
+ "or\n\n"
+ "Artikelgewicht3,7 Kg\n"
+ "Produktabmessungen60 x 46";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}