import re
regex = re.compile(r"^Produktabmessungen\K(.+)", flags=re.MULTILINE)
test_str = ("Artikelgewicht3,7 Kg\n"
"Produktabmessungen60,4 x 46,5 x 42 cm\n\n"
"or\n\n"
"Artikelgewicht3,7 Kg\n"
"Produktabmessungen60 x 46 x 42\n\n"
"or\n\n"
"Artikelgewicht3,7 Kg\n"
"Produktabmessungen60 x 46")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")