import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w.-]+(?![^\"]*\"(?:(?:[^\"]*\"){2})*[^\"]*$)";
final String string = "my_var == \"Hello world!\" foo /(^*#&^$ \n"
+ "\"hello\" foobar \"hello\" FOO \"hello\" baz\n"
+ "Hi foo, I said \"hello\" $&@^$(@$)@$&*@(*$&";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}