$re = '/[\w.-]+(?![^"]*"(?:(?:[^"]*"){2})*[^"]*$)/';
$str = 'my_var == "Hello world!" foo /(^*#&^$
"hello" foobar "hello" FOO "hello" baz
Hi foo, I said "hello" $&@^$(@$)@$&*@(*$&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);