re = /[\w.-]+(?![^"]*"(?:(?:[^"]*"){2})*[^"]*$)/
str = 'my_var == "Hello world!" foo /(^*#&^$
"hello" foobar "hello" FOO "hello" baz
Hi foo, I said "hello" $&@^$(@$)@$&*@(*$&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end