re = /(.)\\1{2,}/
str = '$subject = \'fffffffffffff\' ;
$subject = \'chat\' ;
$subject = \'fffffffffffffffbbbc\' ;'
# Print the match result
str.match(re) do |match|
puts match.to_s
end