using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\[]*product[^\]]*\]";
string input = @"[products-tab collection=""frontpage,new,all-1"" title=""BEST SELLING"" nav=""true"" style=""product-loop-swatch"" rows=""2"" items=""8"" header=""style-1""]
[products-deal product=""apple-iphone-se,armani-exchange-brown-leather-watch-ax2181"" title=""DEAL OF THE DAY""]
[blog blog=""news"" desc=""If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!"" style=""style-2""]
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}