import Foundation
let pattern = #"\[[^\[]*product[^\]]*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
[products-tab collection="frontpage,new,all-1" title="BEST SELLING" nav="true" style="product-loop-swatch" rows="2" items="8" header="style-1"]
[products-deal product="apple-iphone-se,armani-exchange-brown-leather-watch-ax2181" title="DEAL OF THE DAY"]
[blog blog="news" desc="If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!" style="style-2"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)