#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),("\d+,\d{2}"),,nomaterwhat$"
Local $sString = "...nomaterwhat13124123,"321,00",,nomaterwhat" & @CRLF & _
"...nomaterwhat12321,"322,20","134,00",nomaterwhat" & @CRLF & _
"...nomaterwhat1321,"211,00",,nomaterwhat" & @CRLF & _
"...nomaterwhat31313,"241,00",,nomaterwhat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")