re = /,("\d+,\d{2}"),,nomaterwhat$/m
str = '...nomaterwhat13124123,"321,00",,nomaterwhat
...nomaterwhat12321,"322,20","134,00",nomaterwhat
...nomaterwhat1321,"211,00",,nomaterwhat
...nomaterwhat31313,"241,00",,nomaterwhat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end