import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(\"\\d+,\\d{2}\"),,nomaterwhat$";
final String string = "...nomaterwhat13124123,\"321,00\",,nomaterwhat\n"
+ "...nomaterwhat12321,\"322,20\",\"134,00\",nomaterwhat\n"
+ "...nomaterwhat1321,\"211,00\",,nomaterwhat\n"
+ "...nomaterwhat31313,\"241,00\",,nomaterwhat";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}