using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\=\""\;\,\$\{\}\_\(\)\.\!\'\-\:\s\/\<\>\w\näöüÄÖÜèéà@]*))@endif";
string input = @"@if('0' == '0')
<div id=""alert"" class=""alert alert-danger"" style=""display: inline-block"">fgh</div>
@endif
<form method=""post"">
<button id=""startLogik"" class=""button"" type=""submit"" name=""start"">fgh</button>
</form>
@if('0' == '1')
<script type=""text/javascript"">
Logik_SrvBsy = ""bsy"";
GetClientName();
Logik_Init("", "", ""web"",""test"",""Start"");
Logik_SPar_fx(""WEB_LOGIN.EMAIL"", ""mail@mail"");
Logik_SPar_fx(""WEB_LOGIN.WEBID"", ""cvb"");
Logik_SPar_fx(""WEB_LOGIN.LANG"", ""cvb"");
Logik_Exec_fx(""Start"");
</script>
@endif";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}