// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\=\"\;\,\$\{\}\_\(\)\.\!\'\-\:\s\/\<\>\w\näöüÄÖÜèéà@]*))@endif"#).unwrap();
let string = "@if('0' == '0')
<div id=\"alert\" class=\"alert alert-danger\" style=\"display: inline-block\">fgh</div>
@endif
<form method=\"post\">
<button id=\"startLogik\" class=\"button\" type=\"submit\" name=\"start\">fgh</button>
</form>
@if('0' == '1')
<script type=\"text/javascript\">
Logik_SrvBsy = \"bsy\";
GetClientName();
Logik_Init(\"\", \"\", \"web\",\"test\",\"Start\");
Logik_SPar_fx(\"WEB_LOGIN.EMAIL\", \"mail@mail\");
Logik_SPar_fx(\"WEB_LOGIN.WEBID\", \"cvb\");
Logik_SPar_fx(\"WEB_LOGIN.LANG\", \"cvb\");
Logik_Exec_fx(\"Start\");
</script>
@endif";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}