package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\^CV_(\w+)?(?:-(\w+))?-Base`)
var str = `EnglUS^CV_Common-Concierge-Base^0^0^0
EnglUS^CV_Common-Base^0^0^0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}