re = /\^CV_(\w+)?(?:-(\w+))?-Base/m
str = 'EnglUS^CV_Common-Concierge-Base^0^0^0
EnglUS^CV_Common-Base^0^0^0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end