const regex = /^(?:\d{1,4}-)?\d{1,10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,4}-)?\\d{1,10}$', 'gm')
const str = `1234567890
123456789
0000-1234567890
000-123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}