re = /^(?:\d{1,4}-)?\d{1,10}$/m
str = '1234567890
123456789
0000-1234567890
000-123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end