$re = '/^(?:\d{1,4}-)?\d{1,10}$/m';
$str = '1234567890
123456789
0000-1234567890
000-123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);