#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!\bNot\b).)*(?=\s+|$)"
Local $sString = "DFE2001 NE Not 1" & @CRLF & _
"CAT11004 TP" & @CRLF & _
"FFE2001 NE Not 3" & @CRLF & _
"AVI2002 NE" & @CRLF & _
"LAB4000 SU" & @CRLF & _
"BA-PRI008 Not 1" & @CRLF & _
"FDD2001 NE Not 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")