re = /^(?:(?!\bNot\b).)*(?=\s+|$)/m
str = 'DFE2001 NE Not 1
CAT11004 TP
FFE2001 NE Not 3
AVI2002 NE
LAB4000 SU
BA-PRI008 Not 1
FDD2001 NE Not 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end