const regex = /([^\s]+)(\<del)(.*?)(\<\/del\>)([^\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s]+)(\\<del)(.*?)(\\<\\\/del\\>)([^\\s]+)', 'g')
const str = `This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}