re = /([^\s]+)(\<del)(.*?)(\<\/del\>)([^\s]+)/
str = 'This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end