$re = '/([^\s]+)(\<del)(.*?)(\<\/del\>)([^\s]+)/';
$str = 'This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
This is the string you want: Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);