import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:[0-9A-Fa-f]{2}(?=([-:\\.]))(?:\\1[0-9A-Fa-f]{2}){5}))";
final String string = "13:14:5f:cD:42:5f\n"
+ "13-14-5f-cD-42-5f\n"
+ "13.14.5f.cD.42.5f\n"
+ "13145fcD425f\n"
+ "13-145f:cD425f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}