re = /(?:(?:[0-9A-Fa-f]{2}(?=([-:\.]))(?:\1[0-9A-Fa-f]{2}){5}))/m
str = '13:14:5f:cD:42:5f
13-14-5f-cD-42-5f
13.14.5f.cD.42.5f
13145fcD425f
13-145f:cD425f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end