const regex = /(?:(?:[0-9A-Fa-f]{2}(?=([-:\.]))(?:\1[0-9A-Fa-f]{2}){5}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[0-9A-Fa-f]{2}(?=([-:\\.]))(?:\\1[0-9A-Fa-f]{2}){5}))', 'gm')
const str = `13:14:5f:cD:42:5f
13-14-5f-cD-42-5f
13.14.5f.cD.42.5f
13145fcD425f
13-145f:cD425f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}