import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0+\\.0+\\.0+\\.0+$)((?:(?:^|\\.)(?:\\d|[1-9]\\d|1\\d{2}|2[-4]\\d|25[0-5])){4})$";
final String string = "123.23.21.21\n"
+ "0.0.0.0\n"
+ "127.0.0.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}