const regex = /^(?!0+\.0+\.0+\.0+$)((?:(?:^|\.)(?:\d|[1-9]\d|1\d{2}|2[-4]\d|25[0-5])){4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0+\\.0+\\.0+\\.0+$)((?:(?:^|\\.)(?:\\d|[1-9]\\d|1\\d{2}|2[-4]\\d|25[0-5])){4})$', 'gm')
const str = `123.23.21.21
0.0.0.0
127.0.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}