re = /^(?!0+\.0+\.0+\.0+$)((?:(?:^|\.)(?:\d|[1-9]\d|1\d{2}|2[-4]\d|25[0-5])){4})$/m
str = '123.23.21.21
0.0.0.0
127.0.0.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end