import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<u>[А-ЯЁ])\n"
+ " (?<l>[а-яё])\n"
+ " (?<b>\n"
+ " (?<=^)(?=[а-яёА-ЯЁ])\n"
+ " |\n"
+ " (?<=[а-яёА-ЯЁ])(?=$)\n"
+ " |\n"
+ " (?<=[^а-яёА-ЯЁ])(?=[а-яёА-ЯЁ])\n"
+ " |\n"
+ " (?<=[а-яёА-ЯЁ])(?=[^а-яёА-ЯЁ])\n"
+ " )\n"
+ ")\n"
+ "(?P>b)\n"
+ " (?:\n"
+ " (?P>l)+(?P>u)(?P>l)+\n"
+ " |\n"
+ " (?P>u)(?P>l)+\n"
+ " |\n"
+ " (?P>l)+(?P>u)\n"
+ " )\n"
+ "(?P>b)";
final String string = "Русское слово имЕющее роВНо ОДНу заглавнуЮ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}