// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?umx)(?(DEFINE)
(?<u>[А-ЯЁ])
(?<l>[а-яё])
(?<b>
(?<=^)(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=$)
|
(?<=[^а-яёА-ЯЁ])(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=[^а-яёА-ЯЁ])
)
)
(?P>b)
(?:
(?P>l)+(?P>u)(?P>l)+
|
(?P>u)(?P>l)+
|
(?P>l)+(?P>u)
)
(?P>b)").unwrap();
let string = "Русское слово имЕющее роВНо ОДНу заглавнуЮ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}