re = /(?(DEFINE)
(?<u>[А-ЯЁ])
(?<l>[а-яё])
(?<b>
(?<=^)(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=$)
|
(?<=[^а-яёА-ЯЁ])(?=[а-яёА-ЯЁ])
|
(?<=[а-яёА-ЯЁ])(?=[^а-яёА-ЯЁ])
)
)
(?P>b)
(?:
(?P>l)+(?P>u)(?P>l)+
|
(?P>u)(?P>l)+
|
(?P>l)+(?P>u)
)
(?P>b)/mx
str = 'Русское слово имЕющее роВНо ОДНу заглавнуЮ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end