const regex = /<script[^>]*>[^<]*<script[^>]*doubleclick[^>]*>[^\r\n]*[\r\n\s]*<noscript><[^>]*tile=1[^>]*><img[^>]*><\/a><\/noscript>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script[^>]*>[^<]*<script[^>]*doubleclick[^>]*>[^\\r\\n]*[\\r\\n\\s]*<noscript><[^>]*tile=1[^>]*><img[^>]*><\\\/a><\\\/noscript>', '')
const str = `<script type="text/javascript">document.write('<script src="http://ad.doubleclick.net/adj/ep_communityhp;kw=top;state='+state+';tile=1;dcopt=ist;sz=728x90;ord='+ord+'?" type="text/javascript"></'+'script>')</script>
<noscript><a href="http://ad.doubleclick.net/jump/ep_communityhp;kw=top;state=alaska;tile=1;sz=728x90;ord=12345678?" target="_blank"><img src="http://ad.doubleclick.net/ad/ep_communityhp;kw=top;state=alaska;tile=1;sz=728x90;ord=12345678?" width="728" height="90" border="0" alt=""></a></noscript>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}