import Foundation
let pattern = #"<script[^>]*>[^<]*<script[^>]*doubleclick[^>]*>[^\r\n]*[\r\n\s]*<noscript><[^>]*tile=1[^>]*><img[^>]*><\/a><\/noscript>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<script type="text/javascript">document.write('<script src="http://ad.doubleclick.net/adj/ep_communityhp;kw=top;state='+state+';tile=1;dcopt=ist;sz=728x90;ord='+ord+'?" type="text/javascript"></'+'script>')</script>
<noscript><a href="http://ad.doubleclick.net/jump/ep_communityhp;kw=top;state=alaska;tile=1;sz=728x90;ord=12345678?" target="_blank"><img src="http://ad.doubleclick.net/ad/ep_communityhp;kw=top;state=alaska;tile=1;sz=728x90;ord=12345678?" width="728" height="90" border="0" alt=""></a></noscript>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}